«

»

Lastpass se rozbil?

Také se Vám po poslední aktualizaci rozbil Lastpass?

Lastpass měl poslední dobou máslo na hlavě, kdy opravoval každý týden nějakou zásadní chybu. Je dobře, že to aspoň přiznali a konali.

Nicméně zřejmě v tom fofru neměli moc času na testování a tak se stalo, že zatímco verze

4.1.45.84 (z 23.3.2017)  na  Win32bit / Chrome 49.0.2623 je funkční bez problémů,

tak následující verze 4.1.45.87 (z 3.4.2017) už ne

s touto verzí totiž .js hází chybu

onloadwff.js: Uncaught SyntaxError: Identifier ‘is_watermark‘ has already been declared

Tato chyba zdá se je jen ve starém chromu 49 (poslední verze pro XP), u novějších verzí jsem na tuto chybu nenarazil a zdají se být funkční.

Řešením je buď použít novější verzi chrome a nebo  – pokud třeba máte windows XP a nemůžete chrome upgradovat –  nezbývá než Lastpass dočasně downgradovat ( a doufat, že to autoři s vydáním příští verze snad opraví )

Pokud se rozhodnete pro to druhé řešení, tak zde naleznete Lastpass verzi 4.1.45.84 ke stažení

abyste zabránili okamžité automatické aktualizaci pluginu na momentálně nejnovější verzi 87 obsah archivu rozbalte do

%USERPROFILE%\Local Settings\Application Data\Google\Chrome\User Data\Default\Extensions\hdokiejnpimakedhajhdlcegeplioah\4.1.45.87_0

(a nikoliv do 4.1.45.84_0 )

Obdobně, pokud bude zlobit v budoucnu nějaká jiná verze, stačí obsah složky nahradit ale přitom zachovat  číslo nejnovější verze v názvu složky

1 comment

  1. bouskam

    vzhledem k tomu, že se s novou verzí 4.1.52.100 situace opět opakovala, rozhodl jsem se zablokovat automatické aktualizace tohoto pluginu, aby se sám nadále už nemohl s každou další aktualizací rozbít. V archivu pod odkazem ke stažení výše je tedy nyní navíc oproti originálu modifikován manifest.json tak, aby nemohlo svévolně dojít k automatické aktualizaci pluginu.
    (originální verze je k dispozici také )

Napsat komentář